Project

General

Profile

Support #912

UPnP receiver plugin stopped working

Added by Jasse about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal

Description

Ok, I've been using the UPnP receiver plugin for a few months with my Onkyo TX-NR809 and Onkyo TX-NR535. It's been working kinda well. I have always been able to control volume, but the volume steps were never correct, and sometimes if I wanted to increase the volume, the volume would decrease instead.

But since a few days back I have lost remote control and can't figure out what the problem is. I have made no changes wo my devices or network intentionally. I can see the TX-NR809 in the Yatse list, I can select it, but I have no control.

I have other automations to control the receiver over network, and everything but Yatse works fine

I have incuded the debug.log

debug.log View (136 KB) Jasse, 02/28/2017 08:56 PM

History

#1 Updated by Tolriq about 1 year ago

  • Tracker changed from Bug to Support

According to the logs you are in streaming mode. Press stop cast in the cast button and you will be directly connected to Kodi with plugin active.

#2 Updated by Jasse about 1 year ago

hmm.. I'm not. I've tried connecting to a cast device and pressing stop cast after to try and force Yatse to stop all casting, but still same issue

https://plus.google.com/u/0/photos/photo/107827180313381855660/6392282545702475490?icm=false

#3 Updated by Tolriq about 1 year ago

Well from the logs except the part where you are streaming there's no error or problems.

Yatse finds the receiver and connect to it.

I also see volume changes

2017-02-28 20:37:15.166 Verbose/WearHelper: [email protected]: Sending new volume : 16

2017-02-28 20:37:16.771 Verbose/WearHelper: [email protected]: Sending new volume : 24

2017-02-28 20:37:18.390 Verbose/WearHelper: [email protected]: Sending new volume : 16

Meaning everything works perfectly. If there's no volume changes then your receiver does lie and change volume on another zone or something.

But via UPnP I have no control over that.

Have you tried to reboot it?

#4 Updated by Jasse about 1 year ago

Well it's odd that it says I'm casting when I'm not, isn't it?

I have had the receiver unplugged from AC for a proper reboot. I have rebooted my router and phone aswell.

Receiver is not showing any volume changes. But I can control volume with Onkyo app. I have checked and all zones but main are disabled.

Also, like I said, this used to work, not beautifully, but enough

#5 Updated by Tolriq about 1 year ago

Well since there's no error I can't tell a lot.

Upnp protocol is not the same as native onkyo one so you can't compare apples and oranges.

Maybe a firmware update?

#6 Updated by Jasse about 1 year ago

Bad comparison with onkyo remote app, just wanted to demonstrate I had network access to it. I'm on the latest FW.

I have now also tried controlling the receiver with UPnP Tool for android https://play.google.com/store/apps/details?id=com.tjjang.upnptool from my phone and volume control works fine with this app. Both vol+, vol- and mute work well, even correct volume steps

#7 Updated by Tolriq about 1 year ago

Well then uninstall Yatse and plugins to start fresh.

But as I try to explain you : The plugin is correctly connected it correctly controls something volume and the something does correctly returns new volume values. Add to that no errors anywhere.

So there's not a lot I can say about the issue, except that the plugin was not updated since a long time.

#8 Updated by Jasse about 1 year ago

Oddly, it's working today. Haven't done anything. Woke up and upnp control is working again... Odd.. Since I've been having issues for some days, and after multiple reboots aswell. Thanks Torrie. Btw Do you know if anyone is working on a onkyo plugin for Yatse?

#9 Updated by Jasse about 1 year ago

Oddly, it's working today. Haven't done anything. Woke up and upnp control is working again... Odd.. Since I've been having issues for some days, and after multiple reboots aswell. Thanks Tolriq. Btw Do you know if anyone is working on a onkyo plugin for Yatse?

#10 Updated by Tolriq about 1 year ago

There was some attempts but no one did finish.

Since I do not own one of those I can't write it.

#11 Updated by Tolriq about 1 year ago

  • Status changed from New to Closed

Also available in: Atom PDF

Go to top