Project

General

Profile

Support #907

Multiple volume controls

Added by Mikk about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal

Description

Evey time I open the app, i get new volume control under android volume dialog

Screenshot_20170226-105219.png View (41.1 KB) Mikk, 02/26/2017 02:47 PM

debug.log View (419 KB) Mikk, 02/26/2017 04:43 PM

Screenshot_20170226-174016.png View (46.7 KB) Mikk, 02/26/2017 04:44 PM

app-release.apk (1.77 MB) Tolriq, 02/26/2017 08:57 PM

ScreenRecord-2017-02-26-22-09-45.mkv (15.4 MB) Mikk, 02/26/2017 09:19 PM

1059
1061

History

#2 Updated by Mikk about 1 year ago

1061

Started with 0 volume controls(full reboot)

ended with 10 volume controls

All I did was Open Yatse, start playing music

Close yatse

Open yatse

Close yatse

Open yatse

Close yatse ....

#3 Updated by Tolriq about 1 year ago

How to you "Close" Yatse?

I see 10 kills of Yatse.

#4 Updated by Mikk about 1 year ago

open "recent items" menu and swipe left

#5 Updated by Tolriq about 1 year ago

  • Tracker changed from Bug to Support

Well then it's not really a bug, you are on purpose killing Yatse process without any way for it to do anything.

If you do not want the volume bars, just uncheck the lockscreen controls option.

#6 Updated by Mikk about 1 year ago

I think, that you can make a service to do that

#7 Updated by Tolriq about 1 year ago

You mixes things, that you maybe not understand ;)

Yatse have lot's of service, but the main issue is that the media is not playing on the device. Yatse does not have to live during playback, and so can be killed.

But if I remove the way to control audio when killed, then you can't restart Yatse to control audio when you need it without unlocking the device loosing 100% of the need of that function.

So if this is what you want, do not use the function and uncheck lockscreen controls or check the option no volume keys.

There still seems to have some odd behavior at OS level or Support Library level as there's no reason for duplicate bars, but from Yatse code point of view nothing I can do.

#8 Updated by Tolriq about 1 year ago

Can you try to reproduce the problem with this mini app and see if you see multiple bars too?

Using the same pattern as with Yatse.

#9 Updated by Mikk about 1 year ago

Unfortunately yes

#10 Updated by Tolriq about 1 year ago

This is a good new and a bad news :)

This looks pretty specific to your device as I can't reproduce here with any device. But since I have a small repro Google will be able to fix it I hope.

Can you make a small video about how you reproduce the problem with this small app? So I can forward.

#11 Updated by Mikk about 1 year ago

Video of how I reproduced

#12 Updated by Mikk about 1 year ago

Mikk wrote:

Video of how I reproduced

Oh, my device is Nexus 5x

#13 Updated by Tolriq about 1 year ago

Yes that I see in logs, is the rom an official stock?

I see you have cheated props to have assistant but any other things added?

#14 Updated by Mikk about 1 year ago

It is lineageos 14.1-20170221, with Assistant and SU

#15 Updated by Tolriq about 1 year ago

Hum ok :( So I won't be able to open an issue at Google for your issue.

You need to open an issue at Lineage OS with this simple APK so they see the problem and fix it.

#16 Updated by Mikk about 1 year ago

Sure enough

Seems like regression

20170213 build do not have this issue

#17 Updated by Tolriq about 1 year ago

  • Status changed from New to Closed

Also available in: Atom PDF

Go to top