Bug #500

Yamaha Receiver plugin doesn't handle DSP mode switch properly

Added by Konstantin almost 2 years ago. Updated almost 2 years ago.




I have Yamaha HTR-8063 receiver and however plugin works for volume control, it doesn't work properly with DSP modes which I can add as a custom command. The problem is that I can switch between any DSP modes but as soon as I go to "Straight / No DSP mode" it will stuck there, any command send will just show "Straight" on the screen. Receiver remote control works fine. I noticed that Straight button on the remote works as on/off switch meaning pressing it will flip between "Straight" mode and last DSP mode, maybe that somehow related to an issue.

Would be great if you can have a look on issue.

By the way PlugAndPlay plugin however can detect receiver fine doesn't work with volume control just saying that receiver returned error 500.


debug.log View (132 KB) Konstantin, 05/19/2016 06:13 AM


#1 Updated by Tolriq almost 2 years ago

As always logs :

Have you just tried to resend the straight command from Yatse.

#2 Updated by Konstantin almost 2 years ago


I've attached a debug file, hopefully you can make some sense of it.

So I've played a bit with it while log was enabled, as long as I stay in DSP mode it will switch between modes, as soon as I click "No DSP" receiver will stay in that mode, clicking the button again or any other buttons will just show on TV screen "Straight" OSD from receiver and no changes, the only way to use remote.

Let me know if you need something else or some other log information.


#3 Updated by Tolriq almost 2 years ago

Well logs does not shows the problem :( I can't reproduce on my own receiver so maybe your receiver needs a specific API, but since I do not own it it's complicated to fix that if it's ever possible.

#4 Updated by Konstantin almost 2 years ago

Tolriq, can I do something to help? Some more testing? I do IT and have experience with programming.

#5 Updated by Tolriq almost 2 years ago

Well not really, I have no time to maintain specific code for each and every different Yamaha receiver that does not respect their own specs :(

If you find the API culprit and a solution that works for all receivers I can implement.

Also available in: Atom PDF

Go to top