Project

General

Profile

Support #1329

Yatse helper script for Kodi error

Added by Alex 17 days ago. Updated 9 days ago.

Status:
Closed
Priority:
Normal

Description

Hi! I updated Openelec from version 6.0 to 8.0.4 on Raspberry Pi and Yatse to 8.4.1 and I have problem with Yatse helper script for Kodi. I receive error when I try to send streamto Kodi by Yatse or when I only try open add-on.

log-2018-06-03-18.52.42.zip (60.5 KB) Alex, 06/03/2018 09:17 PM

log-2018-06-03-18.55.38.zip (62.9 KB) Alex, 06/03/2018 09:17 PM

History

#1 Updated by Tolriq 17 days ago

File "/storage/.kodi/addons/script.yatse.kodi/lib/share.py", line 12, in
import youtube_dl
File "/storage/.kodi/addons/script.module.youtube.dl/lib/youtube_dl/init.py", line 43, in
from .extractor import gen_extractors, list_extractors
File "/storage/.kodi/addons/script.module.youtube.dl/lib/youtube_dl/extractor/init.py", line 9, in
from .extractors import *
File "/storage/.kodi/addons/script.module.youtube.dl/lib/youtube_dl/extractor/extractors.py", line 22, in
from .adn import ADNIE
File "/storage/.kodi/addons/script.module.youtube.dl/lib/youtube_dl/extractor/adn.py", line 8, in
from ..aes import aes_cbc_decrypt
ValueError: bad marshal data (unknown type code)

Seems your Open Elec lack some basic Python things.

You need to report that to them as the Youtube dl plugin from official repository seems broken on that version.

#2 Updated by Alex 17 days ago

Tolriq wrote:

File "/storage/.kodi/addons/script.yatse.kodi/lib/share.py", line 12, in
import youtube_dl
File "/storage/.kodi/addons/script.module.youtube.dl/lib/youtube_dl/init.py", line 43, in
from .extractor import gen_extractors, list_extractors
File "/storage/.kodi/addons/script.module.youtube.dl/lib/youtube_dl/extractor/init.py", line 9, in
from .extractors import *
File "/storage/.kodi/addons/script.module.youtube.dl/lib/youtube_dl/extractor/extractors.py", line 22, in
from .adn import ADNIE
File "/storage/.kodi/addons/script.module.youtube.dl/lib/youtube_dl/extractor/adn.py", line 8, in
from ..aes import aes_cbc_decrypt
ValueError: bad marshal data (unknown type code)

Seems your Open Elec lack some basic Python things.

You need to report that to them as the Youtube dl plugin from official repository seems broken on that version.

But I can send You-Tube stream from my tablet.

#3 Updated by Tolriq 16 days ago

You have no idea how I hate such answers :)

Your car does not work, the fact that the car next to it works have nothing to do with your car issue doesn't it?

I can't know what you do on your tablet but the issue you have right now and reported to me is caused by the reason I just gave you logs don't lie.

You can of course not believe me and think it's Yatse fault or you can contact open elec so they fix the issue.

You can workaround the issue for youtube by uninstalling the Yatse plugin in Kodi, but you'll be in limited mode and the fact that it works will still not be tied to Yatse but Open Elec issue.

#4 Updated by Alex 16 days ago

Tolriq wrote:

You have no idea how I hate such answers :)

Your car does not work, the fact that the car next to it works have nothing to do with your car issue doesn't it?

I can't know what you do on your tablet but the issue you have right now and reported to me is caused by the reason I just gave you logs don't lie.

You can of course not believe me and think it's Yatse fault or you can contact open elec so they fix the issue.

You can workaround the issue for youtube by uninstalling the Yatse plugin in Kodi, but you'll be in limited mode and the fact that it works will still not be tied to Yatse but Open Elec issue.

You probably didn't understand me. I'm sending the stream from the same tablet with Yatse from the cinema-program (among other things, on the 6 version is working) and they don't start, but when I launch from the attachment YouTube, everything is alright. But I understand you. Surprisingly, that the script itself doesn't run for configuration. Thanks

#5 Updated by Tolriq 16 days ago

The script is broken by a bug on your Open Elec install ;) Not much I can do if they do not fix it :(

#6 Updated by Tolriq 9 days ago

  • Status changed from New to Closed

Also available in: Atom PDF

Go to top