Project

General

Profile

Support #1320

sync button on the show widget seems to update the movie widget (android)

Added by jeroen 23 days ago. Updated 9 days ago.

Status:
Closed
Priority:
Normal

Description

When i press the sync button on the show widget on my phone there didn't appear to happen anything except an Yatse icon appeared saying is was synchronizing library.
But i did notice that the movie widget did sync after pressing the sync button from the show widget.
The sync button on the movie widget itself seems to work properly.
Thanks in advance

debug.log View (826 KB) jeroen, 05/29/2018 07:57 PM

debug.log View (11.3 MB) jeroen, 05/29/2018 10:29 PM

History

#1 Updated by Tolriq 22 days ago

  • Tracker changed from Bug to Support

Please add logs https://yatse.tv/redmine/projects/yatse/knowledgebase/articles/20

Both widgets will refresh after any sync but each widget does correctly only start sync of it's media type. if Yatse says it's syncing then it's syncing ;) Maybe you mix Yatse cache syncing and starting a scan on Kodi library that is not done like that but require doing it from Yatse in custom commands.

#2 Updated by jeroen 22 days ago

Tolriq wrote:

Please add logs https://yatse.tv/redmine/projects/yatse/knowledgebase/articles/20

Both widgets will refresh after any sync but each widget does correctly only start sync of it's media type. if Yatse says it's syncing then it's syncing ;) Maybe you mix Yatse cache syncing and starting a scan on Kodi library that is not done like that but require doing it from Yatse in custom commands.

I can reliably reproduce the bug, and added a debug.log file of it.
this was my procedure doing so.
1, Changed the watched status from the most recent entry from both movies and shows from watched to unwatched in Kodi's interface not using Yatse.
2. Taped the sync button in the bottom left corner of the show widget.
3. Yatse icon appears in notification bar saying "background library synchronization" (but in dutch)
4. The washed status of the movie in the widget changes, the watched status of the show doesn't.

This also happens when i add or remove entries from the library.

I hope this helps.

#3 Updated by Tolriq 22 days ago

Well the logs does not show that.

2018-05-29 19:44:51.716 Verbose/YatseCommandService: [email protected]: Processing : org.leetzone.android.yatsewidget.ACTION_MEDIA_SYNC - Movie - null - 80 - false

It shows that the widget with id 80 did ask for a movie sync.

The sync occurs then your widgets are updated.

2018-05-29 19:44:54.537 Verbose/WidgetManager: [email protected]: Updating widget Episodesv1: 79
2018-05-29 19:44:54.555 Verbose/WidgetManager: [email protected]: Updating widget Moviesv1: 80

Showing that widget with id 80 is indeed your movie widget.

So from Yatse point of view all is normal and working as intended.

Now the question is why a click on the movie widget is triggered when clicking on the tv show one.

Maybe try to remove both widgets from your screen and add them again after a reboot. Don't know what your launcher is doing but it's doing something.

#4 Updated by jeroen 21 days ago

same result i'm afraid.
I am using smart Launcher 5, i also did try using the stock oneplus launcher.
But with the same result as well

#5 Updated by Tolriq 21 days ago

Well this is impossible from Yatse point of view as Yatse can't invent the numbers they are given by the OS during the creation of the display and everything match id 80 is movies and the event is sync movies.

So it is certain that the event that is sent is the event associated with the button of the movie widget. And all those widgets events are not managed at all by Yatse it's 100% full OS so there's nothing I can do on my side about the issue for sure.

You can uninstall Yatse, install fresh and only add the show widget to see what happens and upload logs.

#6 Updated by jeroen 21 days ago

I did a fresh install.
With only the show widget, it appeared to work properly.
But when i add the movie widget as well, the problem returns.
After i remove the movie widget, the show widget doesn't work the next time.
however it does work after that.

#7 Updated by Tolriq 21 days ago

Well logs show that you added the show widget as 103 and that it worked
Then you added the movie as id 106 and it stopped working.
Then removed it and it worked.
Then added new movie as 107 and it stopped working again
Then removed

And the ids did follow so there's clearly a bug on your OS. Just never saw it before and have no idea how this is even possible.

#8 Updated by Tolriq 9 days ago

  • Status changed from New to Closed

Also available in: Atom PDF

Go to top