Project

General

Profile

Support #1200

local music streaming

Added by Alexander about 2 months ago. Updated 13 days ago.

Status:
Closed
Priority:
Normal

Description

Dear Tolriq,

I use Yatse on daily basis and I love its great functionality.
I just recently discovered the possibility to stream local music files from my android phone via Yatse to Kodi, however I have encountered an issue with that.

Situation:
I have started casting an album to Kodi and locked my phone.
Once the first track has finished, the playback doesn't continue with the next track, unless I reactivate the display of my phone.
Then the playback continues with the next track. After one or two tracks, the playback stops again until I activate the screen of my phone and so on and so on.
This behaviour was tested on two different android devices (LG V500 Android 7.1.2 and Huawei Mate 9 with Android 7.0)

I thought that might have to do with the power saving feature of android, so I checked, but Yatse is listed under the exceptions (the app doesn't get closed when the phone is locked).
If I use the app "bubble UPNP" to cast the music to Kodi, the playback works flawlessly.

May you can give me a hint.

Thanks in advance.
DSLeX

P.S. the debug file is from the Mate 9 with Android 7.0

debug.log View (500 KB) Alexander, 01/01/2018 02:17 PM

Yatze+kodi-logs.7z (731 KB) Alexander, 01/02/2018 08:38 PM

Yatse-playstore-armeabi-v7a-final.apk (10.1 MB) Tolriq, 01/03/2018 10:28 PM

Yatse-and-Kodi_logs_2018-01-14.zip (75.4 KB) Alexander, 01/14/2018 08:12 PM

debug.log View (1.19 MB) Alexander, 01/14/2018 08:39 PM

Settings.zip (551 KB) Alexander, 01/20/2018 04:54 PM

History

#1 Updated by Tolriq about 2 months ago

Logs does not show any problem.

I'd need Kodi logs + details about at what song the issue occurs;

Have you tried the option High perf wifi in expert / expert settings ?

#2 Updated by Alexander about 2 months ago

The error appears with every music album (mp3) that I have tested.
I have observed this behaviour with two android devices (1xphone 1x tablet) and three different Kodi installations (2x Libreelec, 1x OSMC).

I ran another test with activated wifi high perf. setting (and a reboot), but it doesn't seem to have an effect.
I noted a timestamp for each event (the time from Kodi on my TV), to give you an impression for the timely order of the events.
Once the music has stopped, I waited for about a minute before I activated my phone again, so that the timestamp has a bigger difference than the playtime of a song plus a few sec pause.

note: at the beginning of the following test ,my phone was connected to the charger (due to battery below 20%).

### EVENTS ###

19:14 start casting music from yatse to kodi (phone on charger)

1st track plays (duration 3:55)
2nd track plays (duration 3:44)
3rd track plays (duration 3:44)

Somewhen in between track 3 I disconnected my phone from the charger.
The music kept on playing until the 3rd track had finished.

19:25 playback stops after 3rd track
19:26 activating the screen, the playback continues with the 4th track (duration 3:48)
19:30 playback stops again
19:32 activating the screen, the playback continues with the 5th track (duration 2:59)
19:35 playback stops again
19:36 activating the screen, the playback continues with the 6th track (duration 3:20)

19:37 connecting phone to charger again, track 6 still playing

19:40 music didn't stop but continued to play the 7th track (duration 3:10)
19:43 music didn't stop but continued to play the 8th track (duration 3:42)
19:47 music didn't stop but continued to play the 9th track (duration 3:11)

19:48 I disconnected the charger from my phone (during the 9th track)

19:50 playback stops again after the 9th track
19:51 activating the screen, the playback continues with the 10th track (duration 3:59)

19:53 I had to activate my phone to look something up for a few secs.

19:55 playback didn't stop after track 10 finished, and continues with track 11 (duration 3:21)
19:58 playback stops again after track 11

20:00 I connected the charger again to the phone, the screen activates and the playback continue with the 12th track (duration 2:35)

20:03 13th track plays (duration 4:44)
20:08 14th track plays (duration 3:33)
20:11 end of album

20:18 deactivating logging

Observation:
The music keeps on playing if I either activate the screen during a song, or while the phone is charging.

Thanks for your help!

#3 Updated by Tolriq about 2 months ago

Well logs shows the issue and it seems something does pause Yatse and prevent it to work. If it happens even with high perf wifi option, then it's often another app that does that or some advanced OS settings.

Normal Android never does that, it kills apps.

Are you using greenify or tools like that?

#4 Updated by Alexander about 2 months ago

I don't use greenify or other 3rd party power optimization apps.
At first I thought it might be the EMUI software on my Huawei Mate 9 might be the reason for this, but even on my LG v500 tablet which has a AOSP Android 7.1.2, Yatse stops the playback when the screen is turned off.

I am no developer by any means, maybe you can assess the following information regarding the 'power saving' issue:
https://source.android.com/devices/tech/power/mgmt

In contrast the app "Bubble UPNP" works even when the screen is off. It just keeps casting the music to Kodi.

Thanks again for your help!

#5 Updated by Tolriq about 2 months ago

I perfectly know this part and Yatse should do what it should to handle those:)

But I think I've found the issue. Yatse release the lock and get it back just after when it should just keep it (Copy paste error during refactor). This may explain why on some devices doze may kick in in that interval.

Please test attached APK and report back.

#6 Updated by Tolriq about 2 months ago

  • Status changed from New to Closed

Well I'll suppose it works :)

#7 Updated by Alexander about 1 month ago

Dear Tolriq,

sorry for the delayed reply, I couldn't find the time before.

I have installed the current play store version 8.1.0 (due to auto updates) and the problem still persists as describes above.
I wasn't able to install the attached 8.0.6 as I get the message that the packet is broken.

#8 Updated by Tolriq about 1 month ago

  • Status changed from Closed to New

Then I need new logs :)

#9 Updated by Alexander about 1 month ago

Please find attached the logs from today

EVENTS

19:50 start casting 1st track to Kodi (duration 3:47)
19:54 playback stops after 1st track
19:55 manually activating the screen, the playback continues with the 2nd track (duration 4:03)
19:58 playback stops again
20:00 manually activated screen and playback continues with 3rd track

Thanks a lot.

#10 Updated by Tolriq about 1 month ago

You mixed up logs. The Yatse one is starting a 20:01 and contains nearly nothing :(

No need to provide Kodi logs for now the issue is pure Yatse.

#11 Updated by Alexander about 1 month ago

I thought you might need the Kodi log as well.
I have cleared both logs before starting the test. It is strange that the Yatse log doesn't start until 20:01 as I selected the debug option before 19:50 (but I didn't check the log before sending).

I am currently performing another test run an I'll update with only the Yatse log soon. Thanks for your fast reply!

#12 Updated by Alexander about 1 month ago

Events

20:19 first track starts (duration 4:15)
20:23 playback stops
20:25 manually activating the screen, the playback continues with the 2nd track (duration 4:00)
20:29 playback stops again
20:31 manually activating the screen, the playback continues with the 3rd track (duration 4:01)
20:35 playback stops again
20:37 manually activating the screen, the playback continues ...
end of test

#13 Updated by Tolriq about 1 month ago

Well logs shows that Yatse correctly keeps the locks.

But your phone still pause the app when it should not, so I'm pretty sure there's a settings at OS level that does that specially on your phone.

Please test again on the tablet with 8.1.0

#14 Updated by Alexander about 1 month ago

The tablet seems to work with the 8.1.0 version, no interruptions any more, but I couldn't get it working on my phone.

I deactivated all power saving settings I could find on my phone (Huawei Mate 9):
https://phandroid.com/2017/02/02/huawei-honor-emui-first-thing/
https://www.geekzone.co.nz/forums.asp?forumid=97&topicid=217985
After each setting I restarted my phone, but still no improvement.

I couldn't find any more settings which might pause Yatse on my phone, even on the internet there were no clues.

The fact that bugs me is that the app BubbleUPnP ran from the very beginning in the background without problems.
Obviously that app handles something differently than Yatse.
I appreciate your effort and I don't want to expect too much, but maybe the devs could help regarding how BubbleUPnP operates in the background?!
https://forum.xda-developers.com/showthread.php?t=1118891

Thank you in advance.

#15 Updated by Tolriq about 1 month ago

Well sorry to disappoint you but there's only me :)

And you can't just look into other apps it would be a little to easy ;)

I can see thousands of post about this issue and many many apps on this device. It seems they all says the same: You need to put an exception for Yatse in OS settings.
There's also some other bugs where you need to allow Yatse to be shown on Lockscreen control by swiping the notification then set it up.
And they suggest to disable memory optimization in Android developer settings.
And another one http://c.mi.com/thread-253478-1-0.html

I'm sorry but there's very little I can do to fight against an OS that does not obey standard Android rules and that I do not own.

#16 Updated by Tolriq about 1 month ago

http://en.miui.com/thread-262288-4-1.html seems to most correspond as it's really a freeze that happens and not a kill.

#17 Updated by Tolriq 13 days ago

  • Status changed from New to Closed

Also available in: Atom PDF

Go to top