Project

General

Profile

Bug #1174

Turning a device's screen back on after a long period of time won't display the playback buttons for the currently playing media.

Added by Jason 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Low

Description

Found:
When my device's screen is turned off for a prolonged time (varies from 5 to 20 minutes), turning the screen back on will show Yatse reconnecting to the playback device (Eg: OSMC - Offline -> OSMC in the top bar), but if media is currently being played back, the playback controls won't appear at the bottom.

Steps to Reproduce:
1. Launch Yatse.
2. Commence Video playback of a long form media (TV Show or Movie).
3. Turn off your device's screen.
4. Wait 5 to 20 minutes.
5. Turn your device's screen back on.

Actual Results:
Yatse reconnects to playback device, but playback controls do not appear.

Expected Results:
Upon reconnecting to the playback device, if media is currently playing, playback controls appear at the bottom.

Notes:
* Rotating the device to force the layout to switch between Landscape or Portrait and vice-versa will force the UI to update and show the playback controls.
* You will find attached a video recording of my device's screen as I was about to stop playback on a piece of media about to end.
* Android: LineageOS - 14.1-20171023-NIGHTLY-bacon
* Yatse: 8.0.1/210524/playstore @ Tolriq

Yatse.mp4 - Issue (701 KB) Jason, 11/29/2017 04:53 AM

debug.log View - Debug Log (3.52 MB) Jason, 11/29/2017 05:11 AM

Debug - 11.30.2017.log View (7.88 MB) Jason, 12/01/2017 01:13 AM

Interact - 11.30.2017.mp4 (10.4 MB) Jason, 12/01/2017 01:13 AM

8.0.5B2.mp4 (145 KB) Jason, 12/07/2017 02:31 AM

History

#1 Updated by Tolriq 6 months ago

Well the logs only shows that your wifi takes lots of time to reconnect, you may want to change Android settings to not disconnect Wifi when screen off.

I'm pretty sure if you wait without moving it will appears but it's taking time because the OS says you are connected but in fact not fully so the first queries to check Kodi status are a little stuck. Yatse can recover from that but needs time.
Rotation of screen just force new checks and gain times. You can navigate to another screen without rotation and it would do the same.

#2 Updated by Jason 6 months ago

Hey Tolriq,

I verified and my phone is set to Always "Keep Wi-Fi on during sleep" in the Wi-Fi configurations.

I reproduce the issue again and when it occurs, I can still skip forward (10 seconds / 10 minutes) using the arrows, change / mute the volume, access the side-panel, but unless I force it to update (Volume rocker, rotate screen, click an item in the side-bar), the phone remains connected and doesn't show the the currently playing Media or the Stop and Pause / Play controls at the bottom.

I've attached an additional log matching the new video I have attached. The UI doesn't update until after I press the physical volume buttons.

#3 Updated by Tolriq 6 months ago

Well I'll try to see if I can find something in the logs but I can assure you that your phone does disconnect from Wifi and only reconnects when screen on.

2017-11-30 17:37:23.499 Verbose/StatusObserver: [email protected]: Screen off
2017-11-30 17:37:23.508 Verbose/StatusObserver: [email protected]: UI status changed to false from true
2017-11-30 17:38:24.320 Verbose/j: [email protected]: Stopping TCPListener
2017-11-30 17:38:24.323 Verbose/j: [email protected]: Disconnecting TCPSocket
2017-11-30 17:44:58.113 Verbose/i: [email protected]: Network Status Check
2017-11-30 17:44:58.114 Verbose/i: [email protected]: Wifi Only
2017-11-30 17:44:58.115 Verbose/i: [email protected]: Not connected

2017-11-30 17:44:58.222 Verbose/YatseEventReceiver: [email protected]: android.intent.action.USER_PRESENT
2017-11-30 17:44:58.223 Verbose/YatseEventReceiver: [email protected]: User present
2017-11-30 17:44:58.223 Verbose/i: [email protected]: Network Status Check
2017-11-30 17:44:58.223 Verbose/i: [email protected]: Wifi Only
2017-11-30 17:44:58.225 Verbose/i: [email protected]: Not connected
2017-11-30 17:44:58.374 Verbose/YatseReceiver: [email protected]: android.intent.action.SCREEN_ON
2017-11-30 17:44:58.374 Verbose/YatseReceiver: [email protected]: Screen On
2017-11-30 17:44:58.375 Verbose/i: [email protected]: Network Status Check
2017-11-30 17:44:58.375 Verbose/i: [email protected]: Wifi Only
2017-11-30 17:44:58.376 Verbose/i: [email protected]: Connected and not SSID forced

#4 Updated by Tolriq 6 months ago

Please join beta and report if things are fixed, I've forced a refresh for edge case like yours that should fix this.

#5 Updated by Jason 6 months ago

Hey Tolriq,

I retested with v8.0.5B2/210527/beta and can confirm the UI is now updating pretty much as soon as the device reconnects.

One fairly minor issue though, once the background image and bottom controls load up, the media information is blank in the bottom controls as well as when you slide it up to expand it (Episode Name, Season / Episode #, Show Name, Thumbnail, and Cover Art). All the remote control buttons are functional and, as with the original issue, the missing media information will appear once you force the UI to update (Volume rocker, rotate screen, click an item in the side-bar).

Thank you very much.

#6 Updated by Tolriq 6 months ago

  • Status changed from New to Closed

Should be ok in final release.

Also available in: Atom PDF

Go to top