Project

General

Profile

Support #1095

Cannot cast streaming video to kodi

Added by David 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal

Description

I am not able to stream a video from my Samsung S8 phone to Kodi. I keep on getting a message saying that Yatse cannot find the Wifi yet I am able to find the Kodi host in the manage host menu and I am also able to use my phone as a remote for the Kodi menu on my TV.

debug.log View - debug log (289 KB) David, 09/05/2017 02:47 PM

Screenshot_20170906-174608.png View (61.5 KB) David, 09/07/2017 04:31 PM

Screenshot_20170906-174736.png View (362 KB) David, 09/07/2017 04:31 PM

Screenshot_20170906-174811.png View (394 KB) David, 09/07/2017 04:31 PM

1313
1314
1315

History

#2 Updated by David 8 months ago

OK will get logs to you but, in the interim, do you think re-installing Yatse may fix this?

#3 Updated by Tolriq 8 months ago

How should I know without the logs and understanding the issue ? :)

#4 Updated by David 8 months ago

Here is my debug log. Hope this helps.

#5 Updated by Tolriq 8 months ago

I do not see any errors except a Kodi youtube plugin error once (Kodi error).

Please describe what you are trying to do with much more details and add screenshots of the error you have.

#6 Updated by David 8 months ago

OK. This is what I am trying to do. As mentioned initially, I am running your app from my Samsung S8 cell phone. So I go to YouTube and start a video. I touch the Share button which opens a window with various options including Yatse. I touch the Yatse button and nothing happens other that I get a quick flash on my the bottom of my cell phone with the message " No connection". I also tried the same sequence with Yatse already open before startting the video on YouTube with the same results. Sorry but I do not have any screen shots to share. Please note as said previously that when I start Yatse on my cell phone I am able to use the phone as a remote.

#7 Updated by Tolriq 8 months ago

Well you never talked about Youtube ;)

Anyway
2017-09-04 14:47:00.983 Verbose/KodiLogger: --> [778] POST http://192.168.0.107:8080/jsonrpc http/1.1 (330-byte body)
2017-09-04 14:47:00.984 Verbose/KodiLogger: --> [778] [{"id":140,"jsonrpc":"2.0","method":"Playlist.Clear","params":{"playlistid":1}},{"id":702,"jsonrpc":"2.0","method":"Playlist.Add","params":{"playlistid":1,"item":{"file":"plugin://plugin.video.youtube/play/?video_id=dTJvOSvvwSk"}}},{"id":241,"jsonrpc":"2.0","method":"Player.Open","params":{"item":{"playlistid":1,"position":0}}}]
2017-09-04 14:47:05.999 Verbose/KodiLogger: <-- [778] HTTP FAILED: java.net.SocketTimeoutException: connect timed out

So your network effectively does not let the request to pass. But Yatse does not display any message about no connection any where.

So maybe you are using some kind of proxy or firewall or security tool that block things.

#8 Updated by David 8 months ago

I do not have any proxy, firewall or other security tool that I can see would block this. I would think that if I had, I would not be able to control Kodi from Yatse unless I'm missing something here. By the way, I also tried this with other than YouTube video streams with no success.

#9 Updated by Tolriq 8 months ago

Well try to screenshot the message or provide logcats.

Logs shows a problem at OS level.

And yes when you share from Youtube Yatse is not foreground application so a firewall or security tool can perfectly block internet in that case ;)

#10 Updated by David 8 months ago

How do you get screenshots from a cell phone? Also, what are logcats?

#11 Updated by Tolriq 8 months ago

It depends on your device, you need to search the documentation. Usually it's power + home or power + vol up or down.

Logcats are OS level logs. If your phone is rooted there's application on Play Store to get them.

#12 Updated by David 8 months ago

1313
1314
1315

Please find attached 3 screenshots from my cell phone. One is from the Yatse screen after I tried to share a video to Kodi. The other two are screenshots of the logcats. Hopefully this helps.

#13 Updated by Tolriq 8 months ago

Can you upload the logcat file? Those extract does not show anything :(

And I'll need new Yatse logs with multiple attempts to play items. All point to OS issue but never seen that before.

Are you sure you have no tools that plays with security or optimizations on your device?

#14 Updated by Tolriq 7 months ago

  • Status changed from New to Closed

Also available in: Atom PDF

Go to top