Project

General

Profile

Feature #1084

Add "play from here" function to episode detail screen

Added by Clemens 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Low

Description

Would be nice, if long-pressing or optional 3D-pressing the play button on the episode's detail screen could add all remaining episodes to the playlist just like if you touch the "play from here" button on the season's screen when an episode in the list is marked.

Screenshot_20170817-191339.png View - Detail screen (941 KB) Clemens, 08/17/2017 08:32 PM

1297

History

#1 Updated by Tolriq 8 months ago

Well the problem is that it lacks context :(

The play from here, play based on what is displayed, for example if you use a smart filter to only have episodes with rating > 8 only those will be queued after. (Same if you are inside a season, only the rest of that season is queued, unlike when in all episode episodes all is queued.

When in details screen, there's no context, so play from here may not give the wanted result depending on what the user was doing before :(

#2 Updated by Clemens 8 months ago

1297

Tolriq wrote:

Well the problem is that it lacks context :(

I thought this might be a problem, but you can still swipe through the (filtered) list when in detail screen. So the context seems to be still there.

I've attached a screenshot of the screen i'm talking of. Just to avoid misunderstandings.

#3 Updated by Tolriq 8 months ago

Not always :(

This is specially a problem when coming from overview screens.

Previously I was thinking about another different function but could not find name so give up. It would not be a play from here that implies context, but a play and queue all next episodes. In that way the function is clear and not dependent on filter or not so consistent.

Maybe you can have a idea for an short and obvious naming for that function that would be clear to be different from the other.

#4 Updated by Clemens 8 months ago

What about "play season from here" and maybe "play series from here" as two buttons which pop-up like the "continue" button if the current details screen is of a tv series episode and you long pressed play.

#5 Updated by Tolriq 8 months ago

  • Status changed from New to Closed

Next version will have Play and queue next episodes in overflow menu from episode details + episodes listed in overviews.

Also available in: Atom PDF

Go to top