Project

General

Profile

Support #1067

Offline Mode

Added by Dzo 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal

Description

Hi,

I just want to ask for this support. Like I am only using my android hotspot to connect to osmc and then... I cant use stream to local device because I still have to turn on my mobile data. Is there a way to do such with out turning on my mobile data?

debug.txt View (16.9 KB) Dzo, 07/28/2017 12:11 PM

Screenshot_2017-07-28-17-45-22.png View (228 KB) Dzo, 07/28/2017 12:13 PM

Screenshot_2017-07-28-17-45-04.png View (222 KB) Dzo, 07/28/2017 12:16 PM

debug.log View (970 KB) Dzo, 07/28/2017 03:05 PM

debug.log View (2.72 MB) Dzo, 07/29/2017 01:07 AM

debug.txt View - Logs using HackConnectivityServices (908 KB) Dzo, 07/29/2017 03:34 AM

Screenshot_2017-07-29-09-20-40.png View - Mobile Data turned off fully working Yatse (238 KB) Dzo, 07/29/2017 03:37 AM

Screenshot_2017-07-29-09-20-57.png View - Xposed (119 KB) Dzo, 07/29/2017 03:37 AM

1275
1277
1281
1282

History

#2 Updated by Dzo 7 months ago

#3 Updated by Tolriq 7 months ago

  • Priority changed from High to Normal

When actually reproducing the issue ? :)

#6 Updated by Tolriq 7 months ago

Logs with the issue happening please ... I have no way to guess what your OS says when you are in that case.

#7 Updated by Dzo 7 months ago

#8 Updated by Dzo 7 months ago

I hope that log file contains it... :)

BTW. I faced these issues when connecting to android hotspot without turning the mobile data on...

  1. Cant use power menu in remote says... error wake on lan
  2. Cant stream movies even thu I purchased unlocked it.

#9 Updated by Dzo 7 months ago

My device is:

LG H502F (LG Magna)
Android 6.0

#10 Updated by Tolriq 7 months ago

Well your OS says that there's no active network connection to anything.

And can't even create global sockets. So it seems your hotspot is not seen as normal Android connection and Yatse can't use it.

Not sure I can do anything about that.

#11 Updated by Dzo 7 months ago

sad life :(

I used Kore Official and I can use the power option. I just wonder why.

Anyways thanks. I hope you could some how find a workaround on next update

#12 Updated by Dzo 7 months ago

I think its really a bug.

I use these:
1. rPi3 OSMC
2. Android A ( Hotspot)
3. Android B

So when I connect Android B to hotspot I can use yatse normally but when I will use the yatse from the hotspot It aint.

I think Yatse is not able to detect a network from direct hotspot host.

#13 Updated by Dzo 7 months ago

*** I turned off my mobile data and still android B can work yatse normally. Please find fix soon. :)

#14 Updated by Dzo 7 months ago

#15 Updated by Dzo 7 months ago

Here's a thing...

I tried to use xposed module hackconnectivityservice to force my connection to wifi even if I am using hotspot and it works...

So I guess, as a normal non-root user, Yatse can't detect or see a connection using mobile hotspot while mobile data is turned off (whereas Kore can)... While a root user can do some workaround but will sacrifice some battery juice.

Suggestion: Maybe in the next update or somehow a fix for this sir is highly appreciated. I love you product sir.

#16 Updated by Dzo 7 months ago

Here's a thing...

I tried to use xposed module hackconnectivityservice to force my connection to wifi even if I am using hotspot and it works...

So I guess, as a normal non-root user, Yatse can't detect or see a connection using mobile hotspot while mobile data is turned off (whereas Kore can)... While a root user can do some workaround but will sacrifice some battery juice.

Suggestion: Maybe in the next update or somehow a fix for this sir is highly appreciated. I love you product sir.

#18 Updated by Tolriq 7 months ago

  • Status changed from New to Closed

Well Kore does not do any check for anything so well you can't really compare. Yatse is more battery efficient than Kore and smarter at when to do things.

But I hope that you do understand that if there's a root hack to fix Android OS bug, that well it's an Android OS bug :)

There's actually no API to properly detect your use case. And battery efficiency is more important than a very very rare use case, specially since you have a workaround that works ;)

#19 Updated by Dzo 7 months ago

There are few raspberry related apps that only works on Wifi connection that when you use hotspot it will still ask for wifi. Anyways my point is... Is there a way Yatse will still work on hotspot host itseft.

Yeah, you are right. Its far way to compare Kore and Yatse... But in terms on that functionality where one could work thru hotspot while the other can't.

For now I could not say its an android os bug not yatse itself. I'm not a developer nor equiped with enough knowledge to say such yet. :)

As for that case... I just wonder if there is a workaround that yatse could detect hotspot as wifi connection... If none, then the only flaw maybe for yatse is that unable to recognized hotspot without turning the mobile data on.

Nonetheless, I appreciate your work. It made things easier...

Also available in: Atom PDF

Go to top